読者です 読者をやめる 読者になる 読者になる

yaotti's diary

QiitaやKobito、Qiita:Teamを作っています。Software is Eating the World

CarbonEmacsアップデート

したら.emacsまわりでエラー。
どうやら元にしたソースがemacs21.5→22になってるらしい。結構違いがありそう。


現在調査中。

[追記]
原因は/Application/Emacs.app/以下にelisp置いてたせいだった。
そらだめでしょうということで~/.emacs.d/以下に自分で追加したelispを移動。



個人的な大きい違いは


透明度の設定は(set-alpha xx xx)→default-frame-alistにて設定

以下のようにする

(setq default-frame-alist
      (append (list '(foreground-color . "azure3")
		    '(background-color . "black")
		    '(border-color . "black")
		    '(mouse-color . "white")
		    '(cursor-color . "white")
		    '(width . 175)
		    '(height . 47)
		    '(top . 0)
		    '(left . 0)
		    '(alpha . (80 60)))    ;;ここ
		    default-frame-alist))

mac-toggle-max-window関数の追加


画面を最大化する関数。これはうれしい。
うれしいので以下を.emacsに追加

;full screen
(define-key global-map "\C-xF" 'mac-toggle-max-window)

大文字にした意味はとくになし。


この2つかな。
あとsession.elが入ってるらしいので、 session.el の設定を変更 - gan2 の Ruby 勉強日記を参考に設定した。